Preparing Practice Exam…
Please wait a moment while the system generates the exam questions, answers, and study session.
Please wait a moment while the system generates the exam questions, answers, and study session.
Question 1 of 125
Free Preview · 125 of 415 · questions 1–125 of 415 are free. Sign up free to sync your progress across devices.
Drag & Drop Scenario
Read the scenario requirements and decide your answer. Click Check Answer below to see the marked solution.
Hotspot Solution:
The correct answer is: DeviceLogonEvents | where DeviceName in ("CFOLaptop", "CEOLaptop", "COOLaptop") and ActionType == FailureReason |s summarize LogonFailures=count () by DeviceName, LogonType Here is a brief explanation of how this query works: The DeviceLogonEvents table is selected, which contains logon events for devices. The where clause filters the events to only include those that have a DeviceName of CFOLaptop, CEOLaptop, or COOLaptop, and an ActionType of FailureReason. This effectively filters the events to only include failed logon events from the specified devices. The summarize clause counts the number of events that match the previous criteria, grouping the results by DeviceName and LogonType. The count() function counts the number of events in each group, and the LogonFailures alias is used to label this count in the resulting output.
Written by other learners. Comments can disagree with the marked answer — check the official documentation when in doubt.
i confirm DeviceLogonEvents | where DeviceName in ("CFOLaptop" , "CEOLaptop" ) and ActionType == "LogonFailed" | summarize LogonFailures=count() by DeviceName , LogonType
ChatGPT says : DeviceLogonEvents | where DeviceName in ("CFOLaptop", "CEOLaptop", "COOLaptop") | where LogonType == "Failed" | summarize FailedSignInCount = count() by DeviceName
The correct answer is: DeviceLogonEvents | where DeviceName in ("CFOLaptop", "CEOLaptop", "COOLaptop") and ActionType == FailureReason |s summarize LogonFailures=count () by DeviceName, LogonType Here is a brief explanation of how this query works: The DeviceLogonEvents table is selected, which contains logon events for devices. The where clause filters the events to only include those that have a DeviceName of CFOLaptop, CEOLaptop, or COOLaptop, and an ActionType of FailureReason. This effectively filters the events to only include failed logon events from the specified devices. The summarize clause counts the number of events that match the previous criteria, grouping the results by DeviceName and LogonType. The count() function counts the number of events in each group, and the LogonFailures alias is used to label this count in the resulting output.